# ThinLinc login fails (No agent server was available)

**URL:** https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291
**Category:** Community Support
**Created:** [17 January 2025 14:36 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291 "2025-01-17T14:36:04Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [17 January 2025 14:36 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/1 "2025-01-17T14:36:04Z")

</div>

Hello,  
I’m running a ThinLinc server on Rocky8 and connecting to it from a Windows client. It was working fine, but now I can’t log in using ThinLinc (I can connect using SSH). This issue started with version 4.17, and updating to version 4.18 did not help.

uname -a:

```auto
Linux eda 4.18.0-553.34.1.el8_10.x86_64 #1 SMP Wed Jan 8 14:44:18 UTC 2025 x86_64 x86_64 x86_64 GNU/Linux

```

vsmserver.log:

```auto
2025-01-17 16:24:41 INFO vsmserver: VSM server version 4.18.0 build 3877 started
2025-01-17 16:24:41 INFO vsmserver.license: Updating license data from disk to memory
2025-01-17 16:24:41 INFO vsmserver.license: License summary: 10 concurrent users. Hard limit of 10 concurrent users.
2025-01-17 16:24:41 INFO vsmserver.session: Loaded 0 sessions for 0 users from file
2025-01-17 16:25:07 INFO vsmserver.session: User with uid 2020 (turtle) requested a new session
2025-01-17 16:25:22 WARNING vsmserver: VSM agent 127.0.0.1 reported failure creating session for turtle
2025-01-17 16:25:22 WARNING vsmserver.loadinfo: Agent 127.0.0.1 failed to start session, Increasing penalty points by 5 to 5
2025-01-17 16:25:22 WARNING vsmserver: No working agents found trying to start new session for turtle
2025-01-17 16:26:01 INFO vsmserver.loadinfo: VSM agent 127.0.0.1 had 5 penalty points, decreasing to 4
2025-01-17 16:26:41 INFO vsmserver.loadinfo: VSM agent 127.0.0.1 had 4 penalty points, decreasing to 3
2025-01-17 16:27:21 INFO vsmserver.loadinfo: VSM agent 127.0.0.1 had 3 penalty points, decreasing to 2
2025-01-17 16:28:01 INFO vsmserver.loadinfo: VSM agent 127.0.0.1 had 2 penalty points, decreasing to 1
2025-01-17 16:28:41 INFO vsmserver.loadinfo: VSM agent 127.0.0.1 had 1 penalty points, decreasing to 0

```

vsmagent.log:

```auto
2025-01-17 16:24:41 INFO vsmagent: VSM agent version 4.18.0 build 3877 started
2025-01-17 16:24:41 INFO vsmagent: My public hostname is 10.10.0.130
2025-01-17 16:25:22 WARNING tl-session: tl-xinit exited with status=1

```

xinit.log:

```auto
xauth: file /var/opt/thinlinc/sessions/turtle/10/Xauthority does not exist
tl-xinit: timeout while waiting for xauth command
xauth: unable to open tmp file "/var/opt/thinlinc/sessions/turtle/10/Xauthority-n"
xauth: unable to write authority file /var/opt/thinlinc/sessions/turtle/10/Xauthority-n

```

I would appreciate any assistance to fix it.

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [26 January 2025 21:10 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/2 "2025-01-26T21:10:54Z")

</div>

Hi @TrutleFX,

> [@TrutleFX](#):
>
> `tl-xinit: timeout while waiting for xauth command`

The issue is this line here - something is causing `xauth` to fail (or time out). Is there anything in the system logs for this user which might indicate what’s going on?

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [28 January 2025 11:00 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/3 "2025-01-28T11:00:51Z")

</div>

Hi @aaron,  
Thanks for your reply!

Unfortunately, I’m not familiar with `xauth` and I’m not sure where its logs are stored. I ran `journalctl -f` during the ThinLinc connection, and the following log was generated (the IP address is removed):

```auto
Jan 28 12:51:00 eda sshd[2234513]: Accepted password for turtle from X.X.X.X port 51729 ssh2
Jan 28 12:51:00 eda systemd-logind[1028]: New session 53 of user turtle.
Jan 28 12:51:00 eda systemd[1]: Started Session 53 of user turtle.
Jan 28 12:51:00 eda sshd[2234513]: pam_unix(sshd:session): session opened for user turtle by (uid=0)
Jan 28 12:51:01 eda systemd-logind[1028]: New session 54 of user turtle.
Jan 28 12:51:01 eda systemd[1]: Started Session 54 of user turtle.
Jan 28 12:51:01 eda tl-session[2234553]: pam_unix(thinlinc:session): session opened for user turtle by (uid=0)
Jan 28 12:51:16 eda tl-session[2234553]: pam_unix(thinlinc:session): session closed for user turtle
Jan 28 12:51:16 eda systemd-logind[1028]: Session 54 logged out. Waiting for processes to exit.
Jan 28 12:51:16 eda sshd[2234513]: pam_unix(sshd:session): session closed for user turtle
Jan 28 12:51:16 eda systemd-logind[1028]: Session 53 logged out. Waiting for processes to exit.
Jan 28 12:51:16 eda systemd[1]: session-53.scope: Succeeded.
Jan 28 12:51:16 eda systemd-logind[1028]: Removed session 53.
Jan 28 12:51:16 eda systemd[1]: session-54.scope: Succeeded.
Jan 28 12:51:16 eda systemd-logind[1028]: Removed session 54.

```

As I understand, the session is starting but it gets closed immediately.

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [29 January 2025 02:40 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/4 "2025-01-29T02:40:00Z")

</div>

Hi @TrutleFX,

Thanks for the logs. `xauth` is having trouble writing your Xauthority file, but it’s not obvious to me as to why. Does the directory `/var/opt/thinlinc/sessions/turtle/10` exist, and is it writable? Have you tried ending all existing sessions first (for example, by rebooting)?

@CendioOssman @samuel any ideas?

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [29 January 2025 10:38 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/5 "2025-01-29T10:38:55Z")

</div>

Hi @aaron,

That directory is created during the connection and exists until the session ends (at which point an error is shown on the client side). After that, it is renamed to `10.<somekindofnumber>.ended`.  
Also, `10` was the initial name of that subdirectory when I noticed that ThinLinc was not working. Sometimes, it is `11`, `15` or `16`.  
For example, after pressing the “Connect” button on the client, the following directory is created:  
`/var/opt/thinlinc/sessions/turtle/15`  
When the session ends (an error is shown on the client side in this case), it is renamed to:  
`/var/opt/thinlinc/sessions/turtle/15.1738145140.ended`

My user has write permissions to that directory. I tried quickly creating a file during the connection, before the session ended (i.e., in `/var/opt/thinlinc/sessions/turtle/15`) and also after the session ended (in `/var/opt/thinlinc/sessions/turtle/15.1738145140.ended`).

The contents of the `/var/opt/thinlinc/sessions/turtle/`:

```auto
total 4
drwxr-xr-x 22 turtle cad 4096 Jan 29 12:30 .
drwxr-xr-x 3 root root 23 Jan 17 14:23 ..
drwx------ 3 turtle cad 151 Jan 17 14:23 10.1737116643.ended
drwx------ 3 turtle cad 151 Jan 17 14:25 10.1737116726.ended
drwx------ 3 turtle cad 151 Jan 17 14:25 10.1737116762.ended
drwx------ 3 turtle cad 151 Jan 17 15:56 10.1737122215.ended
drwx------ 3 turtle cad 151 Jan 17 15:57 10.1737122249.ended
drwx------ 3 turtle cad 151 Jan 17 16:11 10.1737123086.ended
drwx------ 3 turtle cad 151 Jan 17 16:19 10.1737123612.ended
drwx------ 3 turtle cad 151 Jan 17 16:25 10.1737123922.ended
drwx------ 3 turtle cad 151 Jan 18 12:34 10.1737196485.ended
drwx------ 3 turtle cad 151 Jan 18 12:46 10.1737197196.ended
drwx------ 3 turtle cad 151 Jan 18 13:25 10.1737199517.ended
drwx------ 3 turtle cad 163 Jan 20 12:57 10.1737370498.ended
drwx------ 3 turtle cad 151 Jan 20 12:59 11.1737370809.ended
drwx------ 3 turtle cad 151 Jan 29 12:05 15.1738145140.ended
drwx------ 3 turtle cad 151 Jan 28 12:14 16.1738059273.ended
drwx------ 3 turtle cad 151 Jan 28 12:50 16.1738061437.ended
drwx------ 3 turtle cad 151 Jan 28 12:51 16.1738061476.ended
drwx------ 3 turtle cad 176 Jan 29 12:15 16.1738145751.ended
drwx------ 3 turtle cad 151 Jan 29 12:16 16.1738145788.ended
drwx------ 3 turtle cad 176 Jan 29 12:19 16.1738145989.ended
lrwxrwxrwx 1 root root 19 Jan 29 12:19 last -> 16.1738145989.ended

```

The contents of the `/var/opt/thinlinc/sessions/turtle/last/`

```auto
total 24
drwx------ 3 turtle cad 151 Jan 29 12:33 .
drwxr-xr-x 22 turtle cad 4096 Jan 29 12:30 ..
drwx------ 2 turtle cad 6 Jan 29 12:19 dev
-rw------- 1 turtle cad 256 Jan 29 12:19 pcsctun-cookie
-rw------- 1 turtle cad 256 Jan 29 12:19 pulse-cookie
-rw------- 1 turtle cad 64 Jan 29 12:19 sessionkey
-rw------- 1 turtle cad 16 Jan 29 12:19 vncpasswd
-rw------- 2 turtle cad 0 Jan 29 12:19 Xauthority-c
-rw------- 2 turtle cad 0 Jan 29 12:19 Xauthority-l
-rw------- 1 turtle cad 308 Jan 29 12:19 xinit.log

```

I tried rebooting the server, but it did not help.

---

<div class="post-metadata">

### Author: ![CendioOssman](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/cendioossman/32/385_2.png) [@CendioOssman](https://community.thinlinc.com/u/CendioOssman)
#### Post date: [29 January 2025 12:07 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/6 "2025-01-29T12:07:00Z")

</div>

Nothing obvious from the logs. Custom changes to SELinux? Could try `sudo setenforce 0` and see if it gets things going.

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [29 January 2025 12:21 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/7 "2025-01-29T12:21:17Z")

</div>

SELinux is disabled.

```auto
sestatus
SELinux status: disabled

```

---

<div class="post-metadata">

### Author: ![CendioOssman](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/cendioossman/32/385_2.png) [@CendioOssman](https://community.thinlinc.com/u/CendioOssman)
#### Post date: [29 January 2025 12:35 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/8 "2025-01-29T12:35:17Z")

</div>

Out of disk space? Quota?

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [29 January 2025 13:38 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/9 "2025-01-29T13:38:42Z")

</div>

Nope, there is 100+ GB of available free space.

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [30 January 2025 05:01 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/10 "2025-01-30T05:01:35Z")

</div>

Hi,

Something is weird, I suspect it is the `Xauthority-c` and `Xauthority-l` files causing the problem. No idea why they have been created, but they’re lock files, and probably preventing `xinit` from doing its thing.

Try removing them, or if you have no active sessions for the user, maybe just get rid of the `/var/opt/thinlinc/sessions/turtle` directory altogether, and try again.

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [30 January 2025 12:31 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/11 "2025-01-30T12:31:10Z")

</div>

Hi @aaron,

Tried rebooting the whole server, deleting `/var/opt/thinlinc/sessions/turtle` directory, but no luck ☹

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [5 February 2025 04:47 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/12 "2025-02-05T04:47:04Z")

</div>

Hi @TrutleFX,

I’m sorry, I’m at a complete loss here… we know that ThinLinc works on Rocky 8, so there must be something about your specific system configuration which is causing the problem.

Do you know if any configuration was changed leading up to the issue? Are you able to re-install ThinLinc on a fresh Rocky 8 install?

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [6 February 2025 11:43 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/13 "2025-02-06T11:43:59Z")

</div>

Hi @aaron,  
There were no changes to the configuration. The only thing that happened was an update.  
Here is the information on which packages were updated: [Updated Packages - Pastebin.com](https://pastebin.com/Zvnv1FEP)  
However, I am not 100% sure that ThinLinc stopped working immediately after the update, as I did not use it for a week or two afterward.

I tried using older kernels (as suggested in other topics), but it did not help.  
I will try installing a clean Rocky8 with ThinLinc on a different machine (or a VM) and check if it works.

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [6 February 2025 20:24 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/14 "2025-02-06T20:24:32Z")

</div>

@TrutleFX that sounds like a plan. Let us know if it still happens on a clean install - if the issue is reproducable, then we can certainly have a look into it for you.

---

<div class="post-metadata">

### Author: ![TrutleFX](https://avatars.discourse-cdn.com/v4/letter/t/db5fbb/32.png) [@TrutleFX](https://community.thinlinc.com/u/TrutleFX)
#### Post date: [27 February 2025 12:58 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/15 "2025-02-27T12:58:40Z")

</div>

Hi,  
I just wanted to provide an update that the issue was indeed with SELinux. It had been disabled a long time ago, and `sestatus` reported that it was disabled (as I showed in a previous comment). However, it seems that, somehow, it became active again, even though it was still reported as disabled. Several other issues appeared alongside ThinLinc, all pointing toward SELinux. Re-disabling it fixed everything, including ThinLinc.

Thanks for your assistance!

---

<div class="post-metadata">

### Author: ![aaron](https://dub1.discourse-cdn.com/flex005/user_avatar/community.thinlinc.com/aaron/32/13_2.png) [@aaron](https://community.thinlinc.com/u/aaron)
#### Post date: [27 February 2025 20:08 UTC](https://community.thinlinc.com/t/thinlinc-login-fails-no-agent-server-was-available/1291/16 "2025-02-27T20:08:01Z")

</div>

Thanks for the update @TrutleFX! Glad you managed to get up and running, if there’s anything else please let us know.
