Web Customizer Server Error

When I go to the Desktop Customizer menu from the ThinLinc admin page I get a server error like below:

Error response
Error code: 500

Message: Internal error on page ‘/desktop/’.

Error code explanation: 500 - Server got itself in trouble.

What can I do to begin troubleshooting this?

Hello @TonyStone

Is it true that you are also trying to run the tlwebadmin (:1010) behind a proxy like you are doing with webaccess in Web Client address forward issue ?

If that’s the case, my answer in that other thread is also applicable in this case, but we have no knowledge about it ever being done.

With best regards,

Hi Martin, I am not trying to run any of it through the HA Proxy server at this point as I ran into issues discussed in my.other post. This issue seems to be unrelated to all of that. I get the server error when I am trying to access it on the same network using the IP address:1010…

Hello @TonyStone

Ok. I’m wondering if your installation of ThinLinc is broken somehow. You should’ve a structure like this:

├── appgroups.tmpl
├── applications.tmpl
├── home.tmpl
├── manapplications.tmpl
├── menustructure.tmpl
└── sysapplications.tmpl

Can you verify this on your server?

Best regards,

I do not have a templates directory in tlwebadm. Completely missing. I tried doing a new installation and it appears to be the same. No templates directory. DISREGAIRD

I do have that directory structure and files! Sorry… It is all there. Now what?

I have something else to add that may be relevant. When I am installing ThinLinc services on my server I am doing it via AnyDesk remote desktop. I notice after getting ThinLinc installed my display resolution when accessing the desktop from anydesk is something like 400x200. In order to make things visible and functional with anydesk i have to run a command xrandr --fb1920x1080(for example)

Is there some conflict happening between Anydesk services and ThinLinc services? Or should I not even consider pursuing issues there?

Did I understand correctly that you now have the correct folder structure? Are you now able to use the Desktop customizer in the ThinLinc Webadm ?

That sounds strange. I have no previous experience with Anydesk so I cannot say for sure if and how it would conflict, but it sounds odd that if it does that. ThinLinc will install it’s own Xorg server and that is what the ThinLinc client will connect to.

Do you have a Anydesk server installed on your ThinLinc server and then you connect from your client device with anydesk client ?

Yes the correct directory structure is in fact in place. I just accidentally missed it when i first responded. Still same server error code 500 when trying to access localhost:1010/desktop

For what it is worth, I completely removed AnyDesk last night and ThinLinc. Reinstalled ThinLinc using basically all defaults and STILL CANNOT access the Desktop Customizer. Is there some place where an error may be getting logged to on that error response? If so I would like to look there for some hints or clues.

Hello @TonyStone

Yes the log for ThinLinc Web administration is located in /var/log/tlwebadm.log


I’m wondering why you are using AnyDesk to your server for accessing these resources, are you not able to point your browser on your local device to the ip of your server:1010 ?

Also, are any other endpoints working, for example :1010/profiles/ or is it just the Desktop Customizer that errors out ?

Best regards,

I will check those logs. It is only the desktop customizer that gives me the error. I can access the admin pages from any end point in my network. No issues there. The reason I use AnyDesk is just for remote configuration of other software or services. I have not been able to reliably get ThinLinc working yet so I am still relying on AnyDesk.


my log. has lots of errors…

Hello @TonyStone

That was interesting!

From your attached log file I was able to see that there’s a line break in in /usr/share/applications/screensavers/glitchpeg.desktop on line 6 in the Comment line. If you remove this linebreak things will most probably work for you.

glitchpeg.desktop is not something ThinLinc has installed, but seems to come from the xscreensaver-data-extra package, is this a Linux Mint system by any chance?

Anyhow. ThinLinc should be more robust than this and not crash, I will make sure to put a bug report for this in our Bugzilla.

Thank you.

Best regards,

I ended up removing all the screen savers. lol… keep it simple! I can now access the Desktop Customizer. But anyway yes this is a Linux Mint system. Is that a possible issues for other features?

So I will have to study the user guides a bit more but my next issue is no sound. I will start a new post for that and see if we can figure that out. :slight_smile:

Also, after playing around with this system I don’t think it is quite what I am after. I mean maybe with some customizations to this system I can make it work…

Here is my goal: I am trying to put together a web desktop solution where I can allow users to access a Desktop running Lazarus so they can either debug their applications or just see a demo of Lazarus and Free Pascal without needing to install a thing on their own desktop. So I thought the safest approach initially would be some sort of dockerized GUI applications with noVNC access. That is how I found ThinLinc! So this certainly seems like a capable product you guys offer I am just not so sure it is what I really want. Specially on a system with limited resources.

I am also thinking I could make a seperate front end that creates a system user on the fly, and builds a basic default home directory with just Lazarus installed in that home directory. Then when the user logs out the desktop account can be destroyed? I don’t see ThinLinc coming with any features to help me with any of that stuff… unless I am missing it? Would be curious to hear if anyone has any recomendations for already existing solutions to my problems or if there is something else out there that I can use along with ThinLinc?

By the way Martin, thanks for your help and patience in solving my issue!

Hello again @TonyStone

Glad to hear that you are able to access TLDC now! :wink:

No, ThinLinc should run fine on Linux Mint - I was just asking regarding Mint because it showed up in my Google results when debugging that glitchpeg.desktop file, seems many other Mint users have stumbled upon that malformed file as well.

Regarding sound, keep in mind that there’s no sound support in ThinLinc webaccess. You can see this page for a Feature lists between the different ThinLinc clients:

I’ve no experience with Lazarus/Freepascal so a bit insure about what resource requirements they have. It kind of sounds like you just want a desktop with a single application, and not a full feature desktop with all of the bells and whistles, so perhaps it might be worth for you to have a look at

With best regards,

The server encountered an unforeseen circumstance that prohibited it from processing the request, as indicated by the HyperText Transfer Protocol (HTTP) 500 Internal Server Error server error response code. This error answer serves as a general “catch-all.”

If you’re experiencing a “500 - Internal Server Error”, please provide relevant logs, such as /var/log/tlwebadm.log that might provide clues for us.