Connection to agent timed out check your settings

I have installed thinlinc server on my Ubuntu 20.04 and its up running. The IP is 128.46.xx.xx. I can ssh to it. However, every time I try to connect through thinlinc, no matter web or client, it tries to Redirecting to ThinLinc server This is not my server address and I don’t know where this comes from. It happens on every client I have tried and I can connect to other servers properly through the same client.

To provide more info, I have only one machine and Thinlinc server installed as Master. Where does this agent come from? I have access to the 1010 admin port and I can ssh to it. Please provide suggestions on what I should do to trouble shoot.

Hello @Andyshen555

Could you describe a bit more about your network setup?
It sounds like there is NAT involved here, and this has been discussed a few times here before,
perhaps this thread can give you some help along the way?

Kind regards,

I have tried this post before starting a new one. My client system is windows and I changed the HOST_ALIASES to Then when I try to ssh, it reports Bad local forwarding specification ‘2222:’
My server is under a static address and I’m trying to access from public networks. My client is connected to a wireless router.


Ok. The agent will choose the ipaddress assigned to its first network interface, in your case this seems to be, and instruct the vsmserver service to tell the client to make a (ssh) connection to this address.

In your case, you will have to change the agent_hostname setting in /opt/thinlinc/etc/conf.d/vsmagent.hconf to the external facing ipaddress (128.46.xx.xx) and the restart the vsmagent service.

systemctl restart vsmagent

Kind regards,

Thanks that works for me. Now I have another question. When I login and click next on the welcome screen, all I get is a blue screen. Does the Ubuntu gnome desktop GUI work with thinking or do I need to install some other GUI?

never mind, it sometimes works but sometimes doesn’t.

Glad to hear that you’re able to connect.

I have some ideas of what might be go wrong here, are you able to share your /var/log/auth.log with me, either here or you can DM me.


I just encountered the same thing on Ubuntu. Make sure you’re not logged in as the same user at the local console when connecting via ThinLinc.