Issues with running applications in ThinLinc session on Linux Mint

Hello, I have a strange problem… I’m using a simple ThinLinc installation on a virtual machine running on the Proxmox platform, with Linux Mint as the operating system and the MATE desktop environment. Everything has been working more or less fine for about a year, but some specific applications, such as the firewall configuration from the Preferences menu, won’t start. However, if I run this application through the noVNC console in Proxmox, everything works fine, so the problem seems to be within the ThinLinc session. Now i have tried a fresh installation of the latest version of Linux Mint and the ThinLinc server, but the problem remains the same. If anyone has any idea what might be causing this, I would appreciate it.

Hi @John,

That does seem strange, it’s nothing that I’ve come across before. Do you get any error messages or pop-ups when the application fails to start?

If you can figure out the path to the binary for those applications which fail, you could try running them from a terminal and see if there is any output which might tell us what’s going on.