Setting up thinlinc over a reverse tunnel

Hi all,

I am trying to run thinlinc over a reverse tunnel but I am stuck on how to properly set up the connection on windows.

The tunnel on the host is set up as:

RELAY_SERVER_PUBLIC_IP:22 is routed to
RELAY_SERVER_PUBLIC_IP:21 is routed to
(I had to use a commonly used port due to client side restrictions.)

Authentication is set up using RSA keys on the host (not the relay server).

Up until here, I am able to log in to the host using ssh on the client side.


However, I was unbale to use thinlinc. After some searching, I read that I have to use HOST_ALIASES for tunnels. To do this on the client side (windows), I created a conf file and start thinlinc in cmd as

tlclient.exe -C tlclient.conf

I tried several options in the conf file, such as

But it does not seem to work. The client does seem to read the conf file correctly, because I get different responses based on how I define HOST_ALIASES.

Is there anyone who knows how I should get thinlinc up and running?

Kind regards,


client version: 4.12.1


I’m not sure if this will completely solve your problem, but the syntax you’re using for the HOST_ALIASES variable is incorrect. See “Configuration Parameters Used by the ThinLinc Client — The ThinLinc Administrator's Guide 4.14.0 build 2408 documentation”.

What you probably want is something like:


1 Like

Ah, that makes sense! Thank you!

1 Like