Arch Linux Installation

I installed and configured ThinLinc on Arco linux (Arch Linux) but I cannot get it to work from my Mac; I keep having the session shutting down as soon as I login; I tried everything and looking at the logs did not help I also went through the documentation but it did not help either… basicaly as soon as it connects and goes trough the process of finding a profile then it starts a session and closes right away. Has anyone run ThinLinc successfully on Arch Linux?

Hello @erasmus, and welcome!

I have no experience myself from running ThinLinc on Arco Linux (or Arch for that matter).
Could you start by sharing your X session log with us? You’ll find it in


Kind regards,

Thank you for the quick response… I was finally able to solve the problem simply by going over the steps needed to run TigerVNC and what made the trick in my opinion is the following (taken straight from the steps to install TigerVPN server)

  1. create the file /etc/X11/xorg.conf.d/10-vnc.conf with the content below:
    Section “Module”
    Load “vnc”

Section “Screen”
Identifier “Screen0”
Option “UserPasswdVerifier” “VncAuth”
Option “PasswordFile” “/root/.vnc/passwd”
2. run the command (you don’t really need the password but I kept it otherwise change the options in the previous step)
x0vncserver -rfbauth ~/.vnc/passwd

BTW why is the Mac client in French and there are no options in the interface or menu to change the language (it just happened that I speak French so it s not a problem for me)

Thank you again and best regards

Hello @erasmus

Those configurations you’ve made, and also x0vncserver, is not a part of ThinLinc at all, so there must be something else that you did to make ThinLinc work. Is it really ThinLinc server you are trying to use on your Linux server?


Hi Martin,

It is definitely ThinLinc that I am now using and it was my intention from the beginning because I was interested in some of its features other similar products did not have; I spent some time before deciding which product to use knowing I did not want to use VNC; to make a long story short after spending a lot time trying to make ThinLinc work I simply gave up on it but since I had to solve my problem I decided to install TigerVNC; as I am going through the installation it came to my mind that the problem with ThinLinc might have been an issue with X11 or the display screen variable (that’s why I provided the snipet of code above as a possible reason why it resolved my issue). After successfully connecting with TigerVNC, I decided to give a try with ThinLinc and it worked like a charm. I have more arch systems to configure so I will pin down exactly where the problem is without using TigerVPN and will post back on this topic.


Hello @erasmus

Glad to hear that you’re using ThinLinc! :slight_smile:

x0vncserver is part of TigerVNC, and makes the local running X display accessible over the VNC protocol. ThinLinc ships with its own X server (Xvnc) and does not need or use any locally installed X server, thus also prevents access to any local X sessions. I’m glad to hear that ThinLinc is now working for you, but as I wrote in my previous post, since ThinLinc does not use those configurations nor x0vncserver, there must have been something else that fixed the issue for you. Regardless, glad to hear that it’s working fine now :slight_smile:

Regarding the language issue seen in the ThinLinc client on macOS, it’s something we’re aware of and is because of a bug in GNU gettext. It’s fixed in later versions of gettext, but have yet found its way into ThinLinc Client.

The bug makes it pick the wrong language if multiple languages are configured, and the observed behavior seems to be that the first non-English language is picked

The only workaround at this time is to remove the unwanted languages
from the list found in “Preferred languages” which you will find
in “System preferences → Language & Region”

The bug is being tracked in our Bugzilla