Issue with Desktop on linuxmint xfce 21.3 Virginia


I have configured the thinlinc server on the linuxmint xfce 21.3, but the desktop show with the client is not the original one it look like this :

I don’t know how to configure the server properly to get the original desktop.
And when i logon with the same user localy on the server, i get the same desktop.

Kind Regards


I’m not entirely sure what you mean. What desktop environment did you expect to be presented with?
Could you show us what desktop environments you have installed on the server? ThinLinc does not come with any desktop environments included, it will use what you have installed on the server.

Show us the output of
ls -al /usr/share/xsessions


Hello thanks for your reply.
Here is the screenshot of the original desktop

Here is the output of the command :

ls -al /usr/share/xsessions/
total 24
drwxr-xr-x 2 root root 4096 jan 9 14:26 .
drwxr-xr-x 322 root root 12288 avr 2 18:03 …
-rw-r–r-- 1 root root 7107 mar 22 2023 xfce.desktop

From that output, it looks like you only have the XFCE Desktop Environment installed. For Cinnamon, I would expect to see

-rw-r--r--   1 root root   268 Jan  4 19:09 cinnamon2d.desktop
-rw-r--r--   1 root root   155 Jan  4 19:09 cinnamon.desktop

Could you describe how you ended up in this situation?

Yes it’s true, because i’ve installed the XFCE linuxmint distibution, so the desktop in the second post is the XFCE desktop, but not the same as the thinlinc client desktop.

So first login on the server give the original desktop like picture in the second post. After a login with the thinlinc client (windows or linux, i’ve tried both) the desktop is modified like the picture in the first post. If i come back locally to the server the desktop is modified and i don’t find a way to come back to the original desktop.


In my lab, I get the same desktop if I log in locally on the server as when I log on with the ThinLinc client. It’s the same user account in both cases.

Are you using different users?

Kind regards,

Thanks for your reply.
I’ve tried both, same and other users. I’ve the issue all the time.
Issue comes after the server has rebooted once.


ThinLinc won’t interfere with what settings for Themes and Appearance are set for the users. I think you’d need to reach out the Mint / XFCE forums.

Kind regards,

Ok thank you for your help.