Really slow session startup - SOLVED


I apologize if this is asked and answered but I couldn’t find any references.

I am evaluating ThinLinc on an Ubuntu system. Using the client from another Ubuntu workstation, it takes an inordinate time for a session to start. The client pauses for exceedingly long times on “Mounting local drives” and on “Waiting for smartcard connection”. Between the two it takes roughly 15 minutes for a session to start. It doesn’t matter if smartcard and local drives are disabled in the client options. Is it a license issue?

Client version is 4.12.1 Build 6733 and server/agent version is 4.12.1.

Thank you for any feedback.

Hello @cyberfarer

This is not a common issue, and its not related to licensing.
Can you describe a bit more about your setup and how you are reaching your thinlinc environment?
Are master & agent running on the same server?
Is your client located on the same LAN segment as your thinlinc server(s) ?


Hi Martin

Thank you for your reply. I’ve got it. The issue was the hosts file. I noticed in logs the server was creating a session on but I had the host name on the local LAN. I adjusted that and now it is very quick. Thank you.

1 Like


Glad to hear that you got it worked out.


1 Like