SSH works, ThinLinc Client doesn't (same key)

I spun up ubuntu and installed ThinLinc server on it.
I can access admin console on port 1010, but having trouble with client

log file from thinclient ends with following
2023-09-11T05:17:41: ssh[E]: debug1: SSH2_MSG_SERVICE_ACCEPT received
2023-09-11T05:17:41: ssh[E]: NEXT AUTHMETHOD: none
2023-09-11T05:17:41: ssh[E]: AUTH FAILURE
2023-09-11T05:17:41: ssh[E]: debug1: Authentications that can continue: publickey
2023-09-11T05:17:41: ssh[E]: NEXT AUTHMETHOD: publickey
2023-09-11T05:17:41: ssh[E]: debug1: Trying private key: C:\SynologyDrive\aws\andrey2021.pem
2023-09-11T05:17:41: ssh[E]: BAD KEY: GENERAL

using same key from prompt
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: andrey2021.pem
debug1: Authentication succeeded (publickey).
Authenticated to ([]:22).
debug1: channel 0: new [client-session]
debug1: Requesting
debug1: Entering interactive session.

I’m not really sure.
How was this key created?
What version of ThinLinc client are you using, and is this on Windows?

If you start the client with debug logging, does it yield any more information? (tlclient -d5 from command line)

This key was generated by AWS.
Windows 4.15.0
The output is from debug (d5) mode.

Thank you for the information.

I’ve been trying to replicate your issue, but have so far been unable to do so, unfortionately :frowning:

I’ve let AWS create both RSA and ED25519 keys for an Ubuntu 22.04 instance, and both have been working fine in ThinLinc 4.15.0 on a Windows 10.

We do have some sanity check code in place when trying to load the private key, and the error you receive is a fallback for the unknowns. It’s hard to help you further since we cannot replicate the issue.

If you attempt to create another key in AWS, do you still get the same error with the new one?

Kind regards,