Unlock Keyring on logon

Running fedora38, whenever I start a new session I cannot unlock my gnome Keyring.

Sometimes the dialog will come up for auth and it unlocks it but a lot of times the dialog does not come up on login, which breaks evolution mail client, and other apps.

I was able to bypass this on KDE couple years ago but I can’t remember how.

What is the solution to this in Gnome? I’m currently launching a wayland session but if x11 is easier I wouldn’t mind switching.

Hi @obZen

Would you mind posting a screenshot of the dialog in question?

You might be seeing polkit dialogs. Bugs in some versions of GNOME cause these dialogs to appear when they shouldn’t. We have a note for how to disable them for RHEL, here:

HI Samuel,

The keyring dialog is very inconsistent, I’ve only seen it pop up once or twice and cannot recreate it now.

I have followed the RedHat post config.

BTW I fixed my gnome-keyring unlock by stumbling on this post:


After this implementation, the keyring is unlocked and everything works great from a remote session. If theres a better way of achieving the same results im willing to give it a shot.

Good to hear that you fixed the unlock! That fix you found should be fine.