Wrong Monitors on creating sesssion

I have following Setup in Windows 1:

Monitor 2: Left Side, 2560x1440
Monitor 1: Center, 3360x1440, Primary
Monitor 3: Right, 1760x1440

When connecting first time to the host (creating session) it puts the resolution of my primary monitor on virtual display 1 instead of two

Putting client into window mode and back again to fullscreen mode does fix it

Could you provide us with a screenshot of the Display settings in the ThinLinc client when in it’s not as you expect it to be, before toggling between window mode / full screen to fix it?


Its fullscreen all monitors

Okay, and what desktop environment are you using in ThinLinc?

The host uses debian12 with cinnamon

Hello @Kapsonfire

I apologize for being somewhat slow to respond, it took me some time to figure out what’s going on, and I’ve been setting up an environment trying to replicate what you’re experiencing.

When changing display settings inside the session, Cinnamon will save those settings to ~/.config/cinnamon-monitors.xml. Upon session creation, those settings will be applied, overruling what the ThinLinc client tries to apply, which will lead up to the behavior you’re observing.

Simply moving this file out of the way should resolve this.

Kind regards,

Hello Martin, its fine for me to wait. You are doing a great job in supporting.

I dont have this file and i’ve never changed the settings inside cinnamon - so its still the thinlinc client which does it wrong…

i think thinlinc client gets the resolutions from screen 1, screen2, screen3 and creates the displays in same order… but in my setup, screen1 is in the center

Anyway… the hint was good. I did setup once in cinnamon (reorder and apply multiple times) and it works on new sessions


Okay. Now that you’ve configured the desired layout in Cinnamon, do you have that cinnamon-monitors.xml? The problem now may become if you create a session from a different client machine, with different monitors, it will try to apply those settings.

Yes - the file is there. For my setup its ok since I will only have 1:1 connection. For multi-client purposes it’s not usable, thats true