Copy paste into session not working first time

Has anyone seen this?

I noticed when I try to copy from my local machine (usually from a web browser) and paste into a Linux window via Thinlinc, it often will not paste the current paste buffer.

I did a bunch of testing… I can copy with ctl-c or context menu ‘copy’ and the behavior is the same. Many times when I attempt to paste the text into an editor or window on my remote linux host, it will paste the previous buffer, but not the one I just copied.

I figured out I can double copy, and it pretty much always pastes correctly… but for some reason it won’t behave the first time.

At first I thought it might be the linux desktop… (I was using KDE in a remote session) so I switched over to XFCE… same result. It doesnt matter what window i am pasting into either… it can be editors, terminals etc…

I am not sure what the backend to Thinlinc is… but as a test I connected to my remote host using X2Go and I was unable to re-create the issue.

This just recently started for me. I am not sure when it started. but it was fairly recent. - I should add I did a server update about 10 days ago… which updated a ton of stuff. but… the problem doesnt seem to exist in X2Go.

My local machine is a windows 10 PC Client 4.16.0 and I am connecting to Ubuntu 20.4 Linux remotely - ithinlinc-server 4.16.0-3491

Any tips are greatly appreciated!

Hi,

This sounds very much like what was reported upstream to TigerVNC tigervncviewer on windows needs to copy twice in order to get clipboard copied to the server · Issue #1586 · TigerVNC/tigervnc · GitHub. In that case, this was limited to KDE.

I tried to replicate your issue, using Windows 10 as a client, and an Ubuntu 20.04 with Xfce4, but experienced no issues.

One theory I had, was that it might give issues if one has KDE installed as well, so
I then installed the KDE on the same server, and I observed the issue described in upstream, when using KDE. But it still worked fine using if I chose Xfce4 as DE.

It might be some details differing your setup from mine, are you still using KDE? If not, would it be possible for you to completely remove KDE and see if the issue goes away in Xfce?

Kind regards,
Martin

@martin Oh wow thanks a ton! That TiverVNC thread described exactly what I was seeing. I am not sure why I was still seeing the issue when running XFCE. Maybe I was testing in the KDE Kate editor out of habit.

Digging around on the Linux box, I did find the setting in the clipboard manager which was targeted in the thread as the culprit - ‘Prevent empty clipboard’.

I just turned that setting off and started testing. So far I have not had any issues!.. WHoohoooo!

Happy days are here again. I cant thank you enough @martin !

Hi @mscroggi,

Ah, glad to hear that you managed to resolve it!

Have a great day,
Martin