How to install ThinLinc Server on Linux Mint

I’m trying to install the ThinLinc server software on my Linux Mint laptop but I am getting the following errors:

Error: PyGTK not found.
PyGTK is required for ThinLinc’s graphical installer.
To install PyGTK, please run this command:
sudo apt install python-gtk2
Would you like to run this command now?
Alternatively, run this program from a terminal without the
DISPLAY environment variable set to get the text mode fallback.

I then try to install pygtk and then get this error:

E: Unable to locate package python-gtk2
Installation failed. Please report this issue to ThinLinc support.
Visit Support | ThinLinc by Cendio for information on how to contact us.
Press Enter to close this terminal…

If I try to run it from the terminal I still get the same errors. I have spent hours trying to figure this out but have been unsuccessful so far. How do I run the program from the terminal without the display environment variable set or how else can I get this to install?

Hello @JumboJoe

Yes we’re aware of this problem with Linux Mint (Ubuntu) and PyGTK,
see Ubuntu® and Debian® | ThinLinc by Cendio. " No profile chooser on Ubuntu 20.04"

There’s also a link[1] to our bugzilla from the Platform Specific Notes there with some additional info and suggestion on how one might get it to work with thirdparty ppa.

Best Regards,
[1] 7508 – No PyGTK on Ubuntu 20.04

Thanks for responding, I managed to get thinlinc to install with some help from someone on a linux mint forum.

I still can’t get it to work though, now it gets to the point where I type my password to login, everything appears to be working but then thinlinc just closes/crashes without any errors

Hello @JumboJoe

I’d recommend that you investigate this further in available logfiles,

I’d suggest /var/opt/thinlinc/sessions/your_username/last/xinit.log
and also on your client log

Best Regards,

You could try my ansible playbook, that prepares some operating systems to be able to install ThinLinc Server.
If you can’t use ansible, you can look in the files:

  • vars/main.yml
  • tasks/pre_debian_ulyssa.yml
    which extra packages needs to be installed.

I have tried it on ubuntu-20-10-standard (groovy) container and Linux Mint 20.1 (ulyssa) virtual machine.

Be warned! This playbook installs old pyhton2 packages from an ubuntu repo.