Observation: Smart Card Not Detected in TL Client on Thin Client - "No smart card available"

Rebooting is the fix, but I offer the below information in-case it sheds light on a possible TL client bug.

Learned that the USB devices on an HP Thin Client (TC) are not hot swapable–from TL’s perspective. In general, pulling the monitor cable or using a KVM to manage deployments will cause the units to lock-up, forcing a reboot. The card readers not being detected by TL surprised me.

After getting smart card access working, I wanted to test performance across all three card reader types. Swapping the existing and second card readers worked well. The third card reader partially locked the TC, in that the TC recognized both the card and reader, but TL never detected the smart card.

Yes, a reboot fixed it, but if you are using one TC as the admin station to setup or testing the POC, plus create cards, you have to capture the history file and other items before rebooting to avoid losing your commands and work in-progress.

In testing with opensc, again the HP thin client saw both the card reader and the card. Every time I insert the card, the certificate field in the TL client window indicated, “No smart card available”. The TL automated detection also failed.

Both lsusb and usb-devices saw the card reader, which is using the usbfs driver with the pcscd program underneath.

Curious as to why the unexpected behavior happens with the TL client. The other TC units worked fine in configuration and testing, so I ensured that they only used one reader to save time.

1 Like

Hello @Bill,

This is not something I was able to reproduce in our lab. Tested on a ThinPro 630 with a few different cards and readers - All were detected properly in ThinLinc client when swapping. Did you have any Certificate Filter applied? (See screenshot)

Good point. No filters in-place. It might be specific to the T530 running (Linux) ThinPro 8.0 SP1. I upgraded last night to SP6 on all the machines. I’ll test it again once I deploy the users and let you know if the updates (potentially) fixed it. Good to know that TL should be able to handle this situation gracefully.