Thinlinc loses keyboard after screensaver

I am new the ThinLinc. I am running the latest version connecting from a Ubuntu LTS 20.01 client to a Centos 7 server (XFCE used for both).

I have run into a problem that makes it almost unusable. I connect to the server and press F8 to go full screen. After being idle for a while my client screensaver kicks in. I unlock my client computer. As expected I am still connected to the full screen server connection. However the keyboard no longer works. The mouse works fine. I cannot press F8 and am basically stuck, unable to recover.

I am not sure if this is repeatable every time, but it has happened several times over the past few days, and all times it related to the client screensaver.

I found this bug: vncviewer loses keyboard focus after unlocking the screen · Issue #1150 · TigerVNC/tigervnc · GitHub

Is there any recovery mechanism? Is it possible on the server to run any command to restore the proper focus? Something that could be added as a mouse clickable menu entry to ThinLinc? I would imagine if the action that takes place when pressing F8 could be added as a menu item to the workspace, it will allow for recovery of the keyboard focus.

You identified the correct issue I believe, here’s the ThinLinc bug for it:

Unfortunately, for now, the best thing we can recommend is to use a different screensaver on your Ubuntu client. This is a bug in the screensaver and there’s not much we can do to solve it at the moment.

If you want to you can add a script on your desktop (or any menu) that you can run by clicking it. This script will disconnect the ThinLinc session, it will not log you out:

vncconfig -disconnect

Another option you have is to configure a MaxIdleTime, this will disconnect your session after a time of inactivity:

I wonder why this does not happen with the X2GO client / server that I was using before? I was using the same screensavers with that?

The likeliest explanation is that you didn’t have “send system keys” in the X2GO client. This is sometimes referred to as “keyboard grab” and it’s what allows you to, for example, Alt-Tab inside the ThinLinc session when in full screen.

Disabling “send system keys” in the ThinLinc Client options is yet another workaround for this. The bug in XFCE’s screensaver only applies to applications that take ownership of the keyboard (grab the keyboard).

Unfortunately, the same bug applies to “xscreensaver” and “light-locker” too.