Client connects does not display host screen

I installed tl-4.15.0 on ubuntu V20.04 server. Install completed. Then installed tl-4.15 client on windows 10 computer. Both computers are linked via unmanned switch. The client connects to server and logs in ok, but only brings up a welcome screen, not the screen of the server I want to remotely access. It will not do anything else. The F8 key shows my connection and screen info and allows me to disconnect. What is the problem?

Hello @Bmuir

At the “Welcome to Cendio ThinLinc” screen, you’d need to click Forward then choose a desktop environment for your session. Could you provide a screenshot to help illustrate your problem, please?

Kind regards,

Problem solved. I was trying to log into the server using the same id as the client. The server didn’t like that. So I created a new used and logged in as that user and all went well.

Surprisingly, earlier version of the software allowed this

Cheers, Bill


Hello @Bmuir,

Creating multiple sessions for the same user account is supported in ThinLinc, but generally not by modern distributions and graphical desktop environments. Hence, this is not a limitation of ThinLinc, but more of how the whole ecosystem with graphical environments in Linux distributions has evolved.

See Why does starting multiple ThinLinc sessions as the same user sometimes fail? for more information.

Happy to hear that you got it resolved, though! :slight_smile:

Kind regards,


I have the same problem with @Bmuir , I solved it by restarting my computer and not logging in to the account that I want to connect. Then, I just connect to the account remotely. Everything works well. So, I don’t think we need to create a new account. Just keeping the account signed out and connecting remotely.

Hope this can help others.